Best practices for performance-tuning SAP R/3 and Oracle database configurations

Part 1 — SAP tools for monitoring R/3 functionality

by Kostas G. Gavrielidis

Performance-tuning your SAP system and database is like walking a tight rope while holding a pole for balance. Hold the pole off-center or drop an end too far and you might not make it to the other side. Keeping a balanced SAP configuration is just as hard. It requires skill, concentration, experience, and motivation. A single change to any of your production SAP system components affects overall performance.

Years of experience performing escalation support has taught me the importance of monitoring and tuning production SAP R/3 and Oracle database configurations both proactively and reactively. Both activities are required on a frequent basis, especially when the load increases, software changes, or hardware improvements have been made to the production system.

The goal for proactive monitoring is to build and later review trend analysis reports to ensure that any new hardware resources such as CPU, disk space, or memory are available to your SAP R/3 system. Proactive monitoring should also alert the SAP DBA whenever a predefined threshold has been reached or exceeded before it becomes an outage.

Reactive monitoring includes measuring long-term performance trends to ensure that you have adequate lead time for hardware and software upgrades. The SAP DBA must be alerted in time to prevent any SAP or Oracle resource problem that could result in a production outage.

This is the first installment of a three-part series that provides a detailed overview of SAP R/3 performance-tuning best practices for production-class configurations running on Unix with the Oracle relational database management system (RDBMS). In part 1, I provide a veteran’s look at the SAP tools available to monitor R/3 functionality that affects database performance. This includes advice and tips you won’t find in SAP’s documentation. Part 2 explains R/3’s Oracle monitoring capabilities and the performance-optimization tools within Oracle. The third and final installment covers
performance-tuning issues related to running SAP R/3 in a Unix environment. Before I describe the SAP tools available for performance tuning, let me review the overall performance-tuning process.

**Note!**

While the suggestions and recommendations I outline in this article series are based on HP Tru64 Unix 5.x configurations, they apply to non-HP configurations as well, since both SAP R/3 and Oracle run on numerous other platforms with very few differences. The primary differences between the supported platforms are in the operating system (OS) tuning areas for seven of the major OS subsystems: VM, RT, PROC, INET, RTG, SOCKET, and IPC.

**Phase 1: Plan**

I learned early on that if you fail to plan, then plan to fail. This is the stage where you identify the hardware platforms, OSs, persistent storage managers, storage subsystems, networks, PC clients, complex applications, operating procedures, and so on in preparation for the proactive review. In addition, planning should include the following non-technical activities:

- Make sure that you have good business reasons for undertaking the performance-tuning review and that you have management support, including the approval of a senior executive.
- Create a written business justification outlining the areas in which the tuning improvements will benefit your user community, your customers, and your business.
- Establish a project schedule with milestones, resources, and review and quality-control processes.
- Assemble a small team made up of a team leader and an expert from every technology area in your SAP R/3 production landscape — for example, an expert for each different OS, storage subsystem, database management system, network, and SAP application.

**Phase 2: Measure and review**

Monitor all key transactions that support your core business processes before and after the tuning improvements for comparison. Create a baseline of the operational aspects of your SAP R/3 production system, such as the time it takes to perform full and incremental backups, all server uptimes, and utilization of key resources such as CPU, memory, storage...
subsystems, and the network. If your tuning does not significantly improve the performance and reliability of your core business transactions, then you may have to explain why you have wasted the company’s resources on the exercise.

**Phase 3: Adjust and improve**

Based on the results of the measure and review phase, make any necessary adjustments. The important adjustment areas include the tuning of the OS first, which mainly involves the seven OS subsystems: VM, RT, PROC, INET, RTG, SOCKET, and IPC. Then make all improvements to the storage subsystem, network, RDBMS, and SAP R/3 kernel parameters.

**Phase 4: Test and qualify**

It is very important to test all adjustments and improvements made during the adjust and improve phase in a test environment, and you must qualify the adjustments and improvements, preferably in a separate environment from the testing environment, prior to deploying them in the production environment. In this phase, you might encounter issues resulting from the changes or from the parameter settings that need to be resolved with the help of SAP support prior to deploying the adjustments and improvements in the production environment.1

**Phase 5: Deploy**

After going live with the adjustments and improvements, you still need to monitor the production environment for days or possibly weeks. You need to track every issue and work to its successful resolution.

Now that you have an understanding of the overall performance-tuning process, I’ll provide more detail on what you should monitor, and the tools SAP provides for monitoring purposes, as well as advice on how to best use them.

1 For more on testing, see the SAP Professional Journal articles “Performance Testing Your SAP System — Best Practices for Preparing Your Test Environment” (January/February 2004) and “Performance Testing Your SAP System — Strategies for Ensuring a Successful Test Execution” (March/April 2004).

---

**What should you monitor?**

SAP R/3 and the Oracle RDBMS are large, complex systems, and it is impossible to cover everything in the monitoring process. **Figure 1** on the next page and **Figure 2** on page 41 show the suggested daily review activities for SAP R/3 and Oracle, respectively; depending on your environment, you may not need to perform all of them. Add your own activities to these lists and make sure everyone involved in the performance-tuning process is aware of the actions required.

On the Oracle side, the sheer number of areas for database checks might make it difficult to review them all daily. You can perform the review on a weekly or monthly schedule — just be sure to do it on a regular basis.

The SAP R/3 DBA should regularly check the status of the following activities in his or her production environment:

- **Backup verification:** Checking individual backups is not sufficient to ensure that your backup strategy is being implemented successfully. You should also periodically check all database backups to ensure that there are no gaps in the backup sequence. Use transaction DB12 (DB Backup Monitor) or navigate to CCMS → DB Administration → Backup logs.

- **Posting error analysis:** Update Management is used to display update requests, analyze problems pertaining to the update, test and debug canceled update requests, display and reset the status of update requests, delete update requests, and display update statistics. Use transaction SM13 (Display Update Records) or navigate to Tools → Administration → Monitor → Update.

- **Tablespace growth:** Check the growth of the tablespaces in the database and the amount of available free space for the tablespaces. Tablespaces that are growing should not be more than 80% full. Use transaction DB02 (Analyze Tables and Indexes) and select “Space-critical objects” under Tables and Indexes, or navigate to Tools → Administration → Computing Center → Management System → Control → Performance Menu → Database → Tables/Indexes.
• **User maintenance, lockouts:** Check the user lock activity to identify and resolve related configuration issues. For user maintenance, use transaction SU01 (User Maintenance) or navigate to Tools → Administration → User Maintenance → Users. For lockouts, use transaction SM12 (Display and Delete Locks) or navigate to Tools → Administration → System Administration → Monitor → Lock Entries.

• **Lock entries:** Review the locks that are currently set and resolve any problems with locks that you no longer need. Use transaction SM12 (Display and Delete Locks) or navigate to Tools → Administration → System Administration → Monitor → Lock Entries.

• **Temporary sequential (TemSe) space administration:** TemSe is used to store objects that are not normally permanently held in the system. For example, the spool system uses TemSe to store output data temporarily. Use transaction SP12 (TemSe Administration) or navigate to Tools → CCMS → Spool → TemSe Administration.

• **Operating System Monitor:** Use the Operating System Monitor to monitor OS resource data that is collected by the SAPOSCOL data collection program. The Operating System Monitor can monitor any of the servers in your SAP landscape. Use transaction OS06 (Local Operating System Activity) or navigate to Tools → CCMS → Control/Monitoring → Performance menu → Operating system → Local → Activity.

**Figure 1** Daily SAP R/3 review activities
• **Job log overview**: Review the status of the background processing jobs. Use transaction SM37 (Overview of Job Collection) or navigate to System → Services → Jobs → Job overview.

• **Locking and unlocking sessions**: Correct sessions or prevent them from running before a specified date. Use transaction SM35 (Batch Input Monitoring) or navigate to System → Service → Batch input → Sessions.

• **Manage spool requests through the output controller**: The SAP spool system is used to spool, format, and print forms and documents. Resolve
issues with spool requests using transaction SP01 (Output Controller) or navigate to Tools → CCMS → Spool → Spool Administration. Authorized administrators can use transaction SPAD (Spool Administration).

- **Transport logs/Workbench Organizer**: Review the transport requests logs from released change requests to analyze and manage transport requests. Use transaction SE01 or SE09 (Workbench Organizer).

- **Alert monitors**: Use the SAP performance menu to see all other expert monitors available for use in your performance analysis of the SAP systems. Use transaction STUN (Performance Monitoring Menu) or navigate to Tools → Administration → Computing Center → Management System → Control → Performance.

- **Database logs daily maintenance**: Monitor Oracle database performance — the data buffer, shared pool, redo log buffer, sorting, and other Oracle indicators — to analyze overall database activity and database resource consumption. Use transaction ST04N (Database Performance Monitor) or navigate to Tools → Administration → Computing Center → Management System → Control → Performance Menu → Database → Activity.

- **System logs**: Review the error messages in the system log file for all the application servers. Use transaction SM21 (Online System Log Analysis).

### Tools for monitoring SAP R/3

As you can see, you have a lot to review. SAP R/3 production environments tend to include important considerations for high availability and disaster tolerance. Furthermore, the SAP R/3 configuration is complex and includes multiple levels of hardware configurations for different business functions.

**Figure 3** illustrates a typical SAP R/3 production environment distributed across a multisite configuration, which includes front-end clients, application servers, and database servers that need to be part of any monitoring activity. Clearly, you have a lot to monitor, but SAP has Basis monitoring and reporting tools designed to do the job. You’ll find them in the Computing Center Management System (CCMS) and in the ABAP Workbench.

**CCMS tools include:**

- CCMS monitor sets, including the Technical Expert Monitor, which contains the most important monitors for performance and problem monitoring
- Alert Monitor, which provides centralized monitoring capabilities for all your production SAP systems
- Operating System Monitor
- Database Alert Monitor
- Tools for monitoring memory configuration
- Work Process Overview
- Workload Monitor
- Application Monitor
- ABAP Workbench tools include:
  - Performance Trace
  - ABAP Runtime Analysis

**Note!**

For a more complete list of transactions, refer to *SAP R/3 System Administration*, by Sigrid Hagemann and Liane Will (SAP PRESS), or review Chapter 13 in *mySAP Tool Bag for Performance Tuning and Stress Testing*, by George Anderson (HP Press/Prentice Hall).

Each of these tools provides its own insight into the performance of your system, and I use all of them every time I have to review any SAP customer production configuration or when I am involved in
any SAP-related crisis. In the next sections, I take you through the tools in more detail and provide some tips on using them effectively in your own performance-tuning projects.

**CCMS monitor sets**

As part of CCMS, SAP provides predefined “monitor sets” for retrieving and reporting metrics using SAP’s centralized monitoring architecture, allowing SAP administrators to easily perform checks on all servers, components, and resources in the SAP R/3 landscape from one centralized server. This greatly facilitates not only problem discovery, but also the diagnosis of the problem.

This activity requires a privileged account to monitor the SAP R/3 production environment. For accountability purposes, I suggest that you request a new user account, separate from the accounts in use by the current SAP administrator. This isolates your work and any actions you take. It also makes it easier to identify and stop any load increase or performance issue that you might cause in the production environment. To confirm that the privileged user account you
a report of all users whose average response time exceeded a particular threshold value.

The Technical Expert Monitor is available through the SAP Easy Access menu. From the main SAP R/3 screen, select Tools → Administration → Computing Center → Management System → Control → Performance or use transaction STUN (Performance Monitoring). You can expand and collapse menus in the navigation area on the left as shown in Figure 5.

**Technical Expert Monitor**

One of the CCMS monitor sets is the Technical Expert Monitor, which is used for performance monitoring. For example, you can use it to create

![CCMS Monitor Sets](image-url)

**Figure 4** CCMS monitor sets

requested has the correct authorization, call transaction RZ20 (Alert Monitor) and see if the CCMS monitor sets can be displayed (Figure 4).
Alert Monitor

CCMS provides an alert monitor to help you monitor and run your SAP R/3 system. It uses the advanced, object-based technology of the CCMS monitoring architecture. Access it via transaction RZ20 or menu path Tools → CCMS → Control/Monitoring → Alert Monitor. The Alert Monitor offers:

• Complete and detailed monitoring of the SAP R/3 system and of all the server systems, along with the monitoring of the database management system
• Color and numeric value indicators for all monitored components — green means a component is okay, yellow indicates a warning, red indicates a problem, and white indicates that there is not enough data to categorize the component
• Generation of alerts if a particular status indicator is not in the green range
• Easy access to methods for analyzing alerts
• Alert tracking and overall alert management

The CCMS Alert Monitor contains two monitors that display the information relating to the OS and to the file system. Use the Operating System Alert Monitor (transaction AL16) to review system performance for possible bottlenecks and to identify...
possible areas of performance degradation (see Figure 6). Once you locate a possible performance issue — e.g., CPU, memory, network, or storage area — you can use third-party tools from outside of SAP and at the OS level to get a deeper and more accurate understanding of the problem.

The Top CPU Users button in Figure 6 provides a graphical representation of the top 15 processes using system CPU power (Figure 7). Information on each process includes the user, current command executing, CPU time, ResSize (the memory resident process size), priority, and utilization percentage for each process. Use this information to identify processes that are excessively consuming resources.

The Filesystem Alert Monitor (transaction AL18) monitors filesystems and their utilization capacity (Figure 8). Filesystems that have less than 80% of their allocated disk space are classified as being in good shape and are represented with a green arrow. Filesystems with 80% or more capacity are represented with a yellow arrow and have the alert reason “Filesystem full,” as shown in Figure 8. When the filesystem becomes full, you will need to add disk space.

Operating System Monitor

SAP R/3 instances run on top of an OS with heavy dependencies on other subsystems, such as storage systems and the network. The OS makes these resources available to all application processes, such as SAP R/3. These resources are also shared by other application processes — the persistent storage manager, for example — that are running on top of the OS.

The OS manages physical and virtual memory, CPUs, file systems, physical disk drives, and network interfaces. Any bottlenecks in these areas can significantly affect SAP R/3 system performance.

The CCMS Operating System Monitor allows you to monitor all resources that SAP R/3 requires. It helps you identify the cause of a particular performance problem and pinpoint the source of the
Best practices for performance-tuning SAP R/3 and Oracle database configurations

Figure 7  The top 15 processes using CPU

Figure 8  Filesystem Alert Monitor screen
problem if it is in the OS. Then, in conjunction with other tools available at the OS level, it can help identify and resolve the issue.

The Operating System Monitor provides performance indicators for all OS resources. It also provides the CPU load average and CPU utilization, memory utilization, OS swapping information, disk storage and utilization information, local area network (LAN) activity, and OS kernel setup and configuration.

To start the Operating System Monitor, use transaction ST06. The resulting report (Figure 9) includes the following information:

- **CPU utilization includes the number of CPUs; CPU utilization during user, system, idle, and I/O wait modes; system calls and interrupts per second; CPU load average for 1, 5, and 15 minutes; and the number of context switches per second.**

- **Memory utilization includes the amount of physical memory available, the page in/page out activities per second, the amount of physical memory free, and the size of page in/page out per second in kilobytes.**

- **Swap utilization includes the amount of configured swap space, free swap space, maximum allowed space, and actual size in kilobytes.**

- **Disk and file system utilization includes the name of the disks with the highest response time, queue depth, and other disk-related attributes, as well as information on file system capacity and the amount of available free storage space.**

- **LAN activity includes a summary of all LAN interfaces configured, along with the number of packets received and sent per second, the errors for received and sent packets per second, and packet collision rates.**

Let’s review some of the items listed in the Operating System Monitor report shown in Figure 9. The CPU will overload if CPU Utilization idle is less than 20%. The Count field displays the number of CPUs in the system. When determining the acceptable parameters for CPU utilization, carefully review all OS

---

**Figure 9** Operating System Monitor report

<table>
<thead>
<tr>
<th>Tue May 4 06:59:55 2004</th>
<th>interval 10 sec.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CPU utilization</strong></td>
<td></td>
</tr>
<tr>
<td>User %</td>
<td>53</td>
</tr>
<tr>
<td>System %</td>
<td>6</td>
</tr>
<tr>
<td>Idle %</td>
<td>41</td>
</tr>
<tr>
<td>Io wait %</td>
<td>0</td>
</tr>
<tr>
<td>System calls/s</td>
<td>17.523</td>
</tr>
<tr>
<td>Interrupts/s</td>
<td>714</td>
</tr>
<tr>
<td>Count</td>
<td>4</td>
</tr>
<tr>
<td>Load average 1 min</td>
<td>2.30</td>
</tr>
<tr>
<td>Load average 5 min</td>
<td>3.54</td>
</tr>
<tr>
<td>Load average 15 min</td>
<td>3.22</td>
</tr>
</tbody>
</table>

| **Memory**              |                  |
| Physical mem avail kb   | 17.825.792       |
| Pages in/s              | 83               |
| Pages out/s             | 0                |
| Physical mem free kb    | 317.720          |
| Kb paged in/s           | 671              |
| Kb paged out/s          | 0                |

| **Swap**                |                  |
| Configured swap kb      | 47.853.568       |
| Free in swap-space kb   | 45.388.848       |
| Maximum swap-space kb   | 47.853.568       |
| Actual swap-space kb    | 47.853.568       |

<table>
<thead>
<tr>
<th><strong>Disk with highest response time</strong></th>
<th>Name</th>
<th>Utilization</th>
<th>Avg wait time ms</th>
<th>Kb transferred/s</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>dsk0</td>
<td>2</td>
<td>0</td>
<td>83</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Response time ms</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Queue</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Avg service time ms</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Operations/s</td>
<td>6</td>
</tr>
</tbody>
</table>

| **LAN (sum)**               |                  |
| Packets in/s               | 1.497            |
| Packets out/s              | 1.396            |
| Collisions                 | 0                |
| Errors in/s                | 0                |
| Errors out/s               | 0                |
The SAPOSCOL and RFCOSCOL programs

SAP R/3 provides two programs that collect pertinent OS information in addition to the Operating System Monitor: SAPOSCOL and RFCOSCOL. SAPOSCOL, which runs in the OS in the background independently of the SAP R/3 instances, collects OS resource configuration information. It collects data on the virtual and physical memory, CPUs, storage subsystems, physical disks, and network interfaces and resources in use. SAPOSCOL then makes this data available to all SAP R/3 instances on a single server through the use of shared memory. A dialog work process then reads the data from the shared memory.

SAPOSCOL differs from other SAP R/3 programs in two ways: You need special authorization to use it, and a single instance of it per server can run independently of the SAP R/3 instances. You can start SAPOSCOL before the SAP R/3 instance and continue to run it after the SAP R/3 instance has stopped. SAPOSCOL collects and records current data every 10 seconds and records hourly averages over the preceding 24 hours. Another background job, SAP_COLLECTOR_FOR_PERFORMANCE, extracts performance data about the previous 24 hours from shared memory and writes it to a performance database. You later can compare this data for one or more servers.

While SAPOSCOL collects OS data when SAP R/3 work processes are running, RFCOSCOL collects OS data from servers where no SAP R/3 work processes are running, such as a dedicated database server. SAP R/3 uses a Remote Function Call (RFC) to remotely start RFCOSCOL, which then reads the SAPOSCOL data from the shared memory and uses an RFC to forward it to the current transaction. The system administrator must maintain special RFC destinations for this in the SAP R/3 system.

considerations. For example, if the work is being done in a timely manner at 100% CPU utilization, then there is no issue. On the other hand, low CPU utilization and a deep run queue might indicate a problem.

Load average for 1, 5, and 15 minutes gives the average number of work processes waiting for a CPU. A load average that is consistently between 1.5 and 3.0 indicates a need for more or faster CPUs.

All pages in the main memory that are not located in the address area of an active process are paged out (“lazy paged out”). In a high-performance system, transaction ST06 shows a large Pages out value and a relatively small Pages in value. (Figure 9 shows the opposite.) This means that many of the Pages out were not overwritten and could be mapped again by a work process without the cost of page file access. Only the Pages in value is important for evaluating the performance of the system, although in Unix environments, any Pages out are considered a bad sign.

You need to ensure that there is enough memory available for the Unix OS after the SAP instance has started. This means you should work to minimize any paging activity from the OS. The more memory that is available to the OS, the less paging occurs.

Paging refers to individual memory pages from disk to memory. On any Unix system, paging and swapping are major performance degradation issues. This is because each process on the system after startup begins to grow in size and needs more memory from the system. If the system cannot find any memory available for use by the process, then it has to force some other in-memory structure out to disk. This causes a page fault and I/O to disk. Depending on the number of processes on any given Unix
system, this activity may be costly in terms of performance.

Mapping activity occurs when the resource load on any given Unix system is too heavy and the OS is forced to swap out to disk the entire process from memory. You can alleviate both of these performance issues by adding resources to the system such as memory or more CPUs.

The Disk section of the report provides statistics such as response time, utilization percentage, and queue length for disks in the system. This can provide valuable information about hot spots in the storage subsystem of the database server during heavy transaction periods.

From the Operating System Monitor, you can compare key performance measurements of the CPU, paging, swapping, and LAN subsystems across all SAP application servers. Let’s walk through these comparisons so that you can identify heavily used systems in your own environment and properly distribute the workload among the application servers.

Call transaction ST06 and click on the Detail analysis menu to get to the Operating System Monitor screen (Figure 10). Then click on the Compare all servers button to get the report for all servers (Figure 11).

Click on the Graphics by column button to see the first of many bar graphs. Figure 12 shows the CPU User Average bar graphs for all servers on a particular day. The graph option buttons on the right generate all server comparison bar graphs for the CPU, paging activity, swap activity, and LAN activity performance categories.

**Database Alert Monitor**

The CCMS Database Alert Monitor provides a live view of database performance for all key database
These graph the average amount of time each server spends on the respective areas.

These graph the maximum and average paging activity per server.

These graph reserved and free swap space, respectively.

These show activities in the LAN interface and not the actual network traffic.

These graph all categories for all servers for the day before or after the current comparison day.

Figure 11  Report comparing all servers for a specific date

Figure 12  Workflow CPU user average for all servers
categories shown in Figure 13. You can access it using transaction STUN or the SAP Easy Access menu. The green, yellow, and red circles show the quality and state of the background processes. The Database Alert Monitor also shows the number of missing database indices along with the date and time when the free space management was checked.

In Figure 13, each category listed in the row is an active button. Clicking on User calls brings you to the top 10 monitor (Figure 14). Here, it lists the top 10 servers and their database activities by user calls. Clicking on the other rows in Figure 13 will show database activity for recursive calls, user rollbacks, CPU used by session (sec/100), table scans, long tables, sorts (memory), sorts (disk), 10 sorts (rows), physical reads, and database block changes. Using the top 10 monitor screens will tell you whether the load is spread evenly over all the systems.

The top 30 database performance report shows historical database performance for the top 30 days of database activity for user calls, recursive calls, user commits, user rollbacks, parses, consistent gets, DB block gets, physical reads, physical writes, table fetch by rowid, table fetch continued row, table scans rows gotten, and table scans blocks read. Access it by calling transaction ST06 and clicking on the Compare recent days button. Figure 15 shows the top 30 user calls. This type of historical information acts as a useful reference to compare against current data.

**Tools for monitoring memory configuration**

Monitor the SAP R/3 system during production operations to ensure that its memory management has the necessary resources and that frequent paging at the OS level does not slow down the system or cause any bottlenecks. The following tools are suitable for monitoring memory:

- The Tune summary (transaction ST02) displays the...
Figure 14  Top 10 servers as they relate to database user calls activity

Figure 15  Top 30 days of database user calls
current status and the memory resource usage for a specific SAP R/3 application server. Be sure to review each application server. A primary value of the Tune summary (Figure 16) is that it shows whether the buffers of the roll and paging areas are as large as the paging files. By comparing them with the Max. use values, you can verify whether the buffer size is sufficient. Note the Extended Memory values for Max. use [kB] and In memory [kB]. Both are 10483.712. This indicates that you should increase the extended memory though the SAP parameter em/initial_size_MB.

The report shows values in the Swaps areas highlighted in red. In this case, there is no problem since the swap space used is not larger than allocated. SAP recommends the size of the swap space be three times larger than the physical memory on a given system and at least 3.5GB.

**Note!**

The value of the extended memory pool size (i.e., parameter em/initial_size_MB) should be big enough to contain all user contexts. The rule of thumb is that the extended memory pool size always should be larger than the extended memory limit specified by the ztta/roll_extension parameter. SAP recommends this to be 10 to 15 times larger than the ztta/roll_extension parameter. All these parameters are shown in the Tune summary.

- The Operating System Monitor (transaction ST06, discussed previously) monitors the available swap space in the host system.
• The CCMS Alert Monitor (transaction RZ20), which I described earlier, provides overall monitoring information on the components of your SAP R/3 system.

• User Overview (transaction SM04 or menu path Tools → Administration → Monitor → System monitoring → User overview, and then Goto → Memory) shows information relative to the amount and type of memory reserved by the user contexts of all users for a specific SAP R/3 application server.

• Work Process Overview (transaction SM50, discussed in the next section) displays the memory resources (when you select the Detail button) that have been reserved for a certain work process. With SM50 (or by running the DPMON program from the OS level), you can monitor work processes while inside the SAP R/3 SAPGUI. DPMON allows you to determine the status of all the work processes in relation to PRIV (private) mode. If work processes are often switched to PRIV mode, you may have to increase the extended memory, or you may have to adjust the limit for the extended memory. For this and all other configuration changes, you must consult with SAP support prior to deploying them into the production environment.

• Systemwide Work Process Overview (transaction SM66) allows you to evaluate information on all the work processes across the system.

• The SAPPFPAR program displays the minimum and maximum requirements for the swap space on an SAP application server. Memory is a limited resource on any system. Programs that are in memory are usually swapped out to a file on disk to allow faster access of the newly loaded program or data structures. SAP recommends a 3GB to 6GB swap space for 32-bit Linux systems and 20GB for 64-bit Unix systems. Because all system applications (SAP and non-SAP alike) share the swap space on any given system, you can determine the swap space requirements for SAP R/3 from the OS level and avoid swap space starvation.

Note!
Many of the monitoring tools are OS-dependent, so make sure you have access to these procedures for monitoring systems on all the various platforms.

Work Process Overview
When an operation mode has been switched, the process overview shows whether the work process types have been changed correctly. To monitor the work processes on the current application server, use the menu path Tools → Administration → Monitor → System monitoring → Process overview from the SAP R/3 initial screen, or use transaction SM50 or SM51.

The system displays an overview of the work processes for the server you are logged into. Information for each work process appears on its own line (Figure 17 on the next page). The Ty. column shows the work process type. For example, DIA is a dialog process, UPD is an update process, BGD is a background process, and so on. Select Detail information on the Work Process Overview screen to display details on the use of memory resources in a particular work process (Figure 18 on page 57).

In Figure 17, the CPU column shows the CPU time associated with each work process. For dialog work processes, CPU time should be unevenly distributed so that the first work process shows the greatest CPU time, and the CPU time should fall off rapidly for subsequent work processes. If all of the work processes consume roughly the same CPU time, then the system is overloaded. You can confirm this using transaction ST06 (Operating System Monitor, discussed previously). Scroll to the right to see the Action and Table columns. If you see a large number of sequential reads, then the associated table scans might cause the poor response time.

Semaphore 6 under the Sem column (not shown in the screenshots) means that the system is out of roll
Figure 17 Work process overview report

area memory and had to go to disk. This is very expensive in terms of performance. Fix this by increasing the roll area memory using the ztta/roll_area parameter. All SAP configuration parameters are stored in files outside the SAP system and at the OS level in what are called instance profile files. SAP profile parameters are used to specify your desired resource setting for your SAP instance. Increasing the roll area parameter ztta/roll_area has the following dependencies on other parameters:

- The ztta/roll_area parameter must be equal to or larger than the ztta/roll_first parameter.
- The roll buffer size parameter rdisp/ROLL_SHM and the maximum roll file size parameter rdisp/ROLL_MAXFS must also be adjusted.

Your transaction SM50 report might show Time column values increasing for a particular process while the CPU time values remain constant or nearly constant. This indicates that a work process is stuck and not taking any more CPU time because it is allocated to a particular user who is waiting on a lock. It is also possible that a poorly written, time-consuming SQL SELECT statement is increasing elapsed time, but the CPU time is not increasing as fast. To find out which work processes are taking too long, click on the CPU button repeatedly. This updates the data on the screen with the new values so you can check to see if the CPU time is increasing. To find the root cause of this issue, identify the type of work the process is tasked with performing.

Since SAP R/3 Basis Release 3.0, SAP supports more than one update server. When an update request is created, the update manager automatically chooses a suitable update server. To maintain efficient load distribution, all update servers are subjected to static evaluation, and the update requests are distributed in a round-robin fashion. Update dispatching of this kind is factory-set to active. Similar to distributing the load, update dispatching also improves the availability of the updating service and thus contributes to an increase in overall system availability. If, for example, you have to bring down an update server, the update manager recognizes this and dispatches updates to the remaining servers.

For a complete list of all the SAP R/3 servers, follow the menu path Tools → Administration → Monitor → System monitoring → Servers from the initial SAP R/3 screen or use transaction SM51 (SAP Application Server Overview). The system displays a list of the SAP R/3 servers in your landscape (Figure 19 on page 58). To display the processes for a particular server, position the cursor on the line containing the server name and then choose Processes.

Transaction SM66 (menu path CCMS → Control/Monitoring → Work process overview) provides a system-wide overview of all the work processes in the SAP system. The system displays the Global Work Process Overview screen, which includes all current work processes (Figure 20 on page 58).
Best practices for performance-tuning SAP R/3 and Oracle database configurations

**Figure 18** Work process overview detail report
The SAP system has a special lock mechanism that synchronizes access to the database. This lock mechanism prevents two transactions from changing the same data simultaneously. Locks are defined generically as lock objects in the data dictionary (DDIC). A lock request is a specific instance of a lock object and locks a certain database object such as a correction or a table entry. Lock entries are usually set and deleted automatically when user programs access a data object and release it again. The SAP lock mechanism is closely related to the update mechanism in R/3.

You can use the lock management functions through transaction SM12 (Display and Delete Locks) or menu path Administrator → System Administrator → Monitor → Lock Entries to check and delete lock entries if the SAP dispatcher, OS, or network connection fails and the dispatcher is not able to delete these lock entries (Figure 21). In this case, invalid lock entries remain effective and block access to the locked data when the system is restarted.

Lock management monitors the lock logic of your system. You can determine the locks that are currently set. Locks for which the backup flag is set, because they have already been transferred to the update task, are highlighted. This enables you to detect and rectify problems, for example, by deleting locks that are no longer required.

Logon load balancing increases the efficiency of various workgroups that have been defined in terms of...
Best practices for performance-tuning SAP R/3 and Oracle database configurations

performance and system resource consumption by distributing users across available application servers based on requirements for workgroup service and load sensitivity. In a system landscape with several application server instances, specific servers are best assigned to specific application workgroups, whereby the available resources and buffers of that server are set specifically to the application and not shared with other applications.

To create or change a logon group, follow the menu path CCMS → Configuration → Logon Groups or use transaction SMLG. The system displays logon group names, instances, and their status. To sort this list, select Group list → Sort and then choose either Sort by group or Sort by instance. From here you can Create entries, Sort by instance, Delete entries, Delete groups, and Delete group assignments.

You can easily monitor a logon group once it is assigned by pressing F5. Use the resulting screen’s output to compare real-time response times to historical values for each group.

To display and edit the response time thresholds for each logon group, select Group list → Format → Extended. If you want to display additional information on a logon group, double-click on an entry in the table or press F2.

In the Create/Change Entry dialog box, you can configure the following options:

- **Group assignment** is the name of the workgroup that is or will be defined. SAP reserves the logon group called SPACE, so do not use that name.

- **Instance (application server)** specifies the name of the instance that supports the class name that was defined above.

- **Response time**, once you define it for one group in an instance, must be defined for all groups using the same instance. The system automatically sets a homogeneous value for all groups that are associated with that instance.

- **Users** represents the maximum number of configured users who can be logged on to an instance. The system automatically sets a homogeneous value for all groups that are associated with that instance.

The values for Response time and Users are thresholds rather than absolute limits. Even if the current

Figure 21 Select Lock Entries screen
value for response time or number of users is higher than the threshold value, you can still log onto another instance. The threshold values influence only the calculation of the current logon server of the logon groups. Transaction SMLG displays the dynamic user distribution: Logon group, Instance, and operation mode Status (Figure 22). A green status indicator means that the threshold is below the limit. Yellow or red indicators mean the threshold has been exceeded. If this happens, you need to rebalance the logon groups.

### Figure 22 Logon group distribution report

<table>
<thead>
<tr>
<th>Logon group</th>
<th>Instance</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>EXTERN</td>
<td>kgg0080_P11_10</td>
<td></td>
</tr>
<tr>
<td>KGG_CORP_USA</td>
<td>kgg0082_P11_13</td>
<td></td>
</tr>
<tr>
<td>KGG_CORP_USA</td>
<td>kgg0084_P11_15</td>
<td></td>
</tr>
<tr>
<td>USA</td>
<td>kgg0085_P11_16</td>
<td></td>
</tr>
<tr>
<td>KGG_GERMANY</td>
<td>kgg0081_P11_12</td>
<td></td>
</tr>
<tr>
<td>KGG_GERMANY</td>
<td>kgg0083_P11_14</td>
<td></td>
</tr>
<tr>
<td>PLANT_GR</td>
<td>kgg0082_P11_13</td>
<td></td>
</tr>
<tr>
<td>PLANT_GR</td>
<td>kgg0084_P11_15</td>
<td></td>
</tr>
<tr>
<td>PLANT_GR</td>
<td>kgg0085_P11_16</td>
<td></td>
</tr>
<tr>
<td>PLANT_GR</td>
<td>p1lap001_P11_03</td>
<td></td>
</tr>
<tr>
<td>PUBLIC</td>
<td>kgg0081_P11_12</td>
<td></td>
</tr>
<tr>
<td>PUBLIC</td>
<td>kgg0083_P11_14</td>
<td></td>
</tr>
<tr>
<td>PUBLIC</td>
<td>p1lap001_P11_03</td>
<td></td>
</tr>
<tr>
<td>PUBLIC</td>
<td>p1lici_P11_02</td>
<td></td>
</tr>
<tr>
<td>RFC</td>
<td>kgg0082_P11_13</td>
<td></td>
</tr>
<tr>
<td>RFC</td>
<td>p1lap001_P11_03</td>
<td></td>
</tr>
</tbody>
</table>

### Figure 23 Workload Monitor shows server statistics
Workload Monitor

Transaction ST03, Workload Monitor, is the basic response-time analysis tool in SAP R/3 (Figure 23). It is an expert tool used by the SAP EarlyWatch and GoingLive teams. In SAP R/3 Release 4.6C, SAP has reworked Workload Monitor as part of the EnjoySAP initiative, enabling you to monitor and evaluate workload statistics more easily. It also lists the database and application servers (Figure 24). This screen instantly shows whether your SAP system is a central system or a distributed system.

ST03 does not always work properly, usually because the SAP administrator has failed to schedule one of two batch jobs, either SAP_COLLECTOR or SAP_COLLECTOR_FOR_PERFMONITOR. The job must be scheduled to run every hour by the DDIC user.

The batch job runs as an ABAP program called RSCOLL00, which in turn refers to a table called TCOLL. The TCOLL table lists a number of ABAP programs that collect performance data for ST03. If the batch job is not set up properly or if the table TCOLL has incorrect contents, then ST03 will not work properly. You can see if the batch job is scheduled with transaction SM37. You can view table
TCOLL with transaction SM31. SAP Note 12103 has information on how to properly set up the batch job and TCOLL for ST03.

You use the Workload Monitor to analyze statistical data from the SAP R/3 kernel (Figure 25). When analyzing the performance of a system, you typically start by analyzing the workload statistics. For example, you can display the totals for all instances and compare the performance of individual instances over specific periods of time. You can use the Workload Monitor to display the:

- Number of configured instances for each SAP system
- Data for all application instances, not just the one you have logged onto
- Transactions used and the users that call them
- Number of users working on the different instances
- Performance history for recent periods for all instances
- Response time distribution and resource consumption for any application server
- Application server workload for today or for a recent period

There are three types of user modes for using the
Workload Monitor — administrator, service engineer, and expert — each of which show a different type of information:

- The administrator mode is the default user mode that SAP recommends you use. It provides quick access to current workload statistics and an overview of all the workload distribution. In this mode you can also display the functions that relate to the collector.

- The service engineer mode provides you with current workload statistics and statistics for the previous week. It also shows an overview of the workload history and distribution, as well as a detailed workload analysis. By default the system displays the total statistics for all application servers.

- The expert mode provides you with all the functions that are available in transaction ST03N. You can display all of the workload data that is available in daily, weekly, and monthly records.

**Note!**
The workload analysis monitor (transaction ST03N) replaces the old workload monitor (transaction ST03) as of SAP Basis 4.6C.

The global workload monitor (transaction ST03G) usually reads the workload from the distributed statistics records (DSR) performance database, which gets data from the statistics files for the individual components once an hour. This means that you usually cannot show any data that is less than an hour old and has not yet been written to the database.

Another function, Last Minutes’ Load, lets you monitor the latest changes in the system performance. It allows direct access to statistics files for the individual components and displays the system performance for a period of your choice — for example, the last 15 minutes. To use this function:

1. Start the global workload monitor by calling transaction ST03G.

2. In the Functions subtree, expand the desired component type and the desired component. Double-click on Last Minutes’ Load.

3. The system displays the Last Minutes’ Load for `<Component>` dialog screen. On this screen, you can make more detailed specifications about the workload that you want to analyze.

   The system displays the usual output area in which the requested workload is output in an SAP List Viewer (ALV) grid control.2

**Application Monitor**

The initial Application Monitor screen (transaction ST07) shows the current number of users for the different SAP modules. The user profile for each listed application consists of the number of logged-on users, the number of active users, and the number of users currently waiting for a request to be processed (see Figure 26 on the next page).

From the screen shown in Figure 27 on page 65, click on the SAP buffer icon to get a list of all the applications and their SAP buffer sizes, namely the Program buffer that contains the compiled SAP programs, the Generic Key buffer that contains the buffered database tables, the Single Record buffer that contains records from tables, and the CUA buffer that contains the menus and buttons from the ABAP screens.

Specify or change the size of a particular SAP buffer using the system profile parameters. Some buffers require multiple parameters for both the size of the buffer and the number of entries in the buffer. In the report shown in Figure 27, for example, the abap/bufferize system parameter specifies the Program buffer size in kilobytes. The zcsa/table_buffer_area parameter specifies the Generic Key buffer size, and the zcsa/db_max_bufftab parameter specifies the number of entries in this buffer.

---

2 For more on the SAP List Viewer, see the SAP Professional Journal articles “A Developer’s Guide to the New ALV Grid Control” (November/December 2000) and “Take a fresh look at the redesigned SAP List Viewer in SAP NetWeaver ’04: Write programs to present tabular data in less time and with fewer lines of code” (November/December 2005).
The Performance Trace modes — SQL Trace, Enqueue Trace, RFC Trace, and Buffer Trace — allow you to monitor the database access of reports and transactions, and database table buffer access in a trace file and to display the performance log as a list. It also provides extensive support for analyzing individual trace records. Use of the Performance Trace tool requires the right authorizations. You also need system authorizations for both Change trace switches and Analyze traces. Specifically, you need authorization STOM for object S_ADMI_FCD for both.

To start a Performance Trace, select Test → Performance Trace from the ABAP Workbench screen or use transaction ST05. Since SAP R/3 4.0B, performance trace contains the following four trace modes (see Figure 28 on page 66):

- SQL Trace allows you to monitor the database access of reports and transactions.
- Enqueue Trace allows you to monitor the locking system.
- RFC Trace provides information about RFCs between instances.
- Buffer Trace allows you to monitor the database table buffers being accessed.

---

Figure 26 Application Monitor user distribution report

The rtbb/buffer_length parameter sets the SingleRecord buffer size, and the rtbb/max_tables parameter sets its number of entries. Lastly, the rdsb/cua/buffersize parameter sets the Common User Access (CUA) buffer size, and its number of entries is determined by its size divided by 2K. The typical setting for the rdsb/cua/buffersize parameter ranges from 3000KB to 6000KB.

Performance Trace

The Performance Trace modes — SQL Trace, Enqueue Trace, RFC Trace, and Buffer Trace — allow you to monitor database access, locking activities, remote calls of reports and transactions, and database table buffer access in a trace file and to display the performance log as a list. It also provides extensive support for analyzing individual trace records. Use of the Performance Trace tool requires the right authorizations. You also need system authorizations for both Change trace switches and Analyze traces. Specifically, you need authorization STOM for object S_ADMI_FCD for both.

To start a Performance Trace, select Test → Performance Trace from the ABAP Workbench screen or use transaction ST05. Since SAP R/3 4.0B, performance trace contains the following four trace modes (see Figure 28 on page 66):

- SQL Trace allows you to monitor the database access of reports and transactions.
- Enqueue Trace allows you to monitor the locking system.
- RFC Trace provides information about RFCs between instances.
- Buffer Trace allows you to monitor the database table buffers being accessed.

---

1 Also see the article “Performance Problems in ABAP Programs: How to Find Them” (SAP Professional Journal, May/June 2003) for more on using the Performance Trace tool.
Best practices for performance-tuning SAP R/3 and Oracle database configurations

Figure 27  Application Monitor SAP buffer report

SQL Trace records all database activity by a particular user or group of users. SAP R/3 takes Open SQL statements and converts them into embedded SQL statements that are then passed to the RDBMS. The SQL Trace records the embedded SQL statements, their parameters, return codes, and the number of entries retrieved, inserted, or deleted, into a file. The log file also contains the runtime of the statement and the place in the application program from which it was called.

Note!
When performing a trace using any of these trace modes, remember to switch off the particular trace mode you are using after you are done so that you do not waste system resources.
SQL Trace provides information on:

- The SQL statements executed by your program
- The values that the system uses for particular database access and changes
- How the system converts ABAP Open SQL statements into standard SQL statements.
- Where your application executes COMMITS
- Where your application repeats the same database access

With Enqueue Trace active, the system records all locking and unlocking activities and related statements that take place in the system for a particular user or a particular group of users. The Enqueue Trace file contains:

- The locking statements executed
- The table names in the lock object
• The name of the program that set the lock
• The lock type
• The lock owner
• The time required to set the lock
• The time required by the enqueue server to release the lock

With RFC Trace active, the system records all RFCs made by a particular user or a particular group of users. The RFC Trace file contains the following:

• Whether the RFC call was successfully executed.
• The total runtime required for the RFC call.
• Which function modules have been called remotely from the program that you just analyzed.
• Whether the RFC communication was a request by an RFC client or a request from an RFC server.
• The technical parameters of the remote instance.
• The instance on which the remote call was executed.
• The number of bytes sent and received in the RFC call.

With Buffer Trace active, the system records all user buffer accesses and related activities. The Buffer Trace contains the following information:

• Buffer operations in use
• All statement executed buffer accesses
• How the buffer is managed

**ABAP Runtime Analysis**

The ABAP Runtime Analysis tool shows how long it takes to process ABAP code from a single statement to a complete transaction. To start the runtime analysis, select Tools → ABAP Workbench, Test → Runtime analysis or use transaction SE30. On the initial screen (Figure 29 on page 68), you can choose any one of the main functions:

• Tips & Tricks takes you to a screen with a list of useful tips for creating good data structures and SQL code. It even lets you review suggested code samples, estimate the time associated with their execution, and write your own code samples and measure the time of their execution for what-if scenarios.
• The options for Transaction, Program, or Function module are used to specify a type of restriction for the runtime analysis of one of these three object types.
• The Measurement Restrictions let you set more specific measurement restrictions in the Variant field of the screen or for the runtime analysis. Examples of specific restrictions include a time interval or an ABAP statement.

**Summary**

In this article, I’ve presented performance-tuning guidelines, procedures, and available tools as an effective method for the monitoring and performance tuning of your SAP and Oracle production environment in order to maintain a high performance state. I also presented areas of focus for consultants and support engineers who are engaged in providing proactive consulting in the SAP enterprise applications space.

Armed with the information and advice in this article, you are ready to start tackling the performance issues that may be lurking in your own SAP R/3

**Note!**

By default all traces are disabled, so you must manually launch them.

---

4 Also see the article “Performance Problems in ABAP Programs: How to Find Them” (SAP Professional Journal, May/June 2003) for more on using the Runtime Analysis tool.
environment. The next installments of this article series build on what you’ve learned here by examining the monitoring and performance optimization tools available for your Oracle databases, as well as performance issues related to running SAP R/3 in a Unix environment to provide a well-rounded resource for your own performance-tuning projects.

**Acknowledgements**

I am grateful to my HP colleagues George W. Anderson, Laurence Oberman, Claus Vestergaard, and Richard White for their valuable review and input on this article.
Answers at your fingertips.

Extend your learning throughout the year with a license to SAP Professional Journal Online, where developers and administrators are never more than an arm’s length away from thousands of best practices and step-by-step tutorials to implement, maintain, and extend SAP R/3 and SAP NetWeaver technology.

www.sappro.com

To learn about licenses for individuals, teams, and entire sites, visit www.sappro.com.